Difference between revisions of "Bubble Shooter Kit Installing the kit"

From gamevanilla wiki
Jump to: navigation, search
Line 6: Line 6:
 
Open Unity (you will need to use Unity 2018.2.4 or higher) and create a new 2D project:
 
Open Unity (you will need to use Unity 2018.2.4 or higher) and create a new 2D project:
  
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation_new_project.png
+
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation/new_project.png
  
 
== Import DOTween into your project ==
 
== Import DOTween into your project ==
Line 22: Line 22:
 
Go to '''Player Settings''' and set the ''Scripting Runtime Version'' field to '''.NET 4.x Equivalent'''.
 
Go to '''Player Settings''' and set the ''Scripting Runtime Version'' field to '''.NET 4.x Equivalent'''.
  
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation_scripting_runtime.png
+
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation/scripting_runtime.png
  
 
== Import Bubble Shooter Kit into your project ==
 
== Import Bubble Shooter Kit into your project ==
Line 28: Line 28:
 
Download and import the [https://assetstore.unity.com/packages/slug/124730 Bubble Shooter Kit] asset into your project. If all goes well, you should not have any errors on the console and you should be able to run the game by opening the Home scene and clicking on the ''Play'' button. Make sure you have added all the scenes (located in the ''BubbleShooterKit/Scenes'' folder) to your build settings:
 
Download and import the [https://assetstore.unity.com/packages/slug/124730 Bubble Shooter Kit] asset into your project. If all goes well, you should not have any errors on the console and you should be able to run the game by opening the Home scene and clicking on the ''Play'' button. Make sure you have added all the scenes (located in the ''BubbleShooterKit/Scenes'' folder) to your build settings:
  
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation_build_settings.png
+
https://wiki.gamevanilla.com/images/bubble_shooter_kit/installation/build_settings.png
  
 
|}
 
|}

Revision as of 02:22, 21 August 2018

Create a new Unity project

Open Unity (you will need to use Unity 2018.2.4 or higher) and create a new 2D project:

new_project.png

Import DOTween into your project

Download and import the free DOTween asset into your project.

Make sure you perform the additional setup step that DOTween requires by selecting the Setup DOTween option in the Tools/Demigiant/DOTween Utility Panel menu.

Setup TextMeshPro in your project

When you create a new 2D project in Unity, the TextMeshPro package is automatically added to it. But you still need to select the Window/TextMeshPro/Import TMP Essential Resources menu option in order to set it up and be able to use it.

Set the scripting runtime version to .NET 4.x

Go to Player Settings and set the Scripting Runtime Version field to .NET 4.x Equivalent.

scripting_runtime.png

Import Bubble Shooter Kit into your project

Download and import the Bubble Shooter Kit asset into your project. If all goes well, you should not have any errors on the console and you should be able to run the game by opening the Home scene and clicking on the Play button. Make sure you have added all the scenes (located in the BubbleShooterKit/Scenes folder) to your build settings:

build_settings.png